P Codes popping up - Chevy HHR Network


SS Specific Service Issues/Repairs Service/Repairs specific to the SS. Turbo-Brembo Brakes-2.0 Engine-Limited Slip Differential-Programmable Display-MU3 Transmission

Reply
 
 
 
Thread Tools Search this Thread
Old 07-26-2017, 04:12 PM   #1
Thread Starter
 
Join Date: 07-26-2017
Location: Norfolk, VA
Posts: 2
P Codes popping up

Hey guys! I have three codes pop up on my check engine light, and was wondering if somethings connecting the three.
P0327: Knock sensor (showed this code 2 times)
P2187: Bank 1 too lean (showed this code 4 times)
P0106: MAP sensor (showed this one once)

The car is running perfectly. I'm having issues with the battery, and plan to replace it next paycheck. Just wondering if there is something that I'm missing. So you guys know, this car has been up north most of her life. Had an issue with the turbo, and just needed to replace some wiring that was rusted from salt. So I also surmise that a connection somewhere needs to be rewired. Thanks in advance for any tips!
Zabalal is offline   Reply With Quote
Old 07-26-2017, 04:41 PM   #2
Premium Member
 
J W Davis's Avatar
 
Join Date: 09-23-2009
Location: Hurst Texas
Posts: 311
Weak battery or high drain will cause many of these faults. I figure the new battery will clear things up.
J W Davis is offline   Reply With Quote
Old 07-26-2017, 04:43 PM   #3
Moderator
 
RJ_RS_SS_350's Avatar
 
Join Date: 05-01-2014
Location: California
Posts: 2,262
Agree, wait and see what happens with a new battery, it might clear them all up.

Well, technically, replacing the battery will clear the codes. I mean they may not come back.
RJ_RS_SS_350 is offline   Reply With Quote
Old 07-26-2017, 05:07 PM   #4
Moderator
 
Oldblue's Avatar
 
Join Date: 10-13-2011
Location: Welland,Ont Canada
Posts: 14,971
Welcome to the site, weak battery , agreed. I see you have a 2009 SS

The voltage not getting to the sensor in the P0327

https://www.obd-codes.com/p0327

Same for the P0106, possibly caused by low voltage or loose ground

https://www.obd-codes.com/p0106

But the P2187 may be because of other issues, have a read here

https://www.obd-codes.com/p2187

So, check the harness at the MAP sensor, check the ground wires, replace the battery as you intended, then watch for the CEL to possibly light up again in a while
Oldblue is online now   Reply With Quote
Old 07-28-2017, 07:10 AM   #5
Thread Starter
 
Join Date: 07-26-2017
Location: Norfolk, VA
Posts: 2
Thank you so much guys! I'll replace the battery first thing Tuesday, and give you guys an update!
Zabalal is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
popping the rev. limiter??? mightymouse HHR SS 6 07-11-2008 10:10 PM
Rear hatch makes a popping sound ? BILL C. Problems/Service/Repairs 14 04-12-2008 03:33 PM
Amp popping rewcolee1 Audio and Video 12 03-30-2007 06:56 PM
popping noise? pontfirebird73 Problems/Service/Repairs 4 07-17-2006 11:49 AM
keep popping inline fuse on my amp slamed87lincoln Audio and Video 17 05-22-2006 07:41 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:23 AM.


Copyright © 2005 - 2017 Internet Brands, Inc. All rights reserved.