Chevy HHR Network Forums
Search

Welcome to the Chevy HHR Network forums. The Chevy HHR Network is the leading resource for Chevy HHR owners.
You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our FREE community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!
If you have any problems with the registration process or your account login, please contact us.

Register Forgot Password?

Problems/Service/Repairs If you have a problem with your HHR, want a tip on repairing or performing a particular service to you HHR here is the place to post!

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread Display Modes
Old 02-14-2011, 12:27 AM   #1
New Member
 
Join Date: 08-09-2006
Location: Southern California
Member #: 1716
Posts: 16
Check out my gallery 
T/C problem

I have 77K miles on my 2006 HHR and now the T/C light comes on and the T/C stays in gear. If you shut the engine off sometimes the light goes off and it goes out of T/C. It is starting to do it more often now.

Any ideas?
ncampbell21 is offline   Reply With Quote
Old 02-14-2011, 08:19 PM   #2
Senior Member
 
Join Date: 04-14-2010
Location: Wisconsin
Member #: 20395
Posts: 342
Check out my gallery 
Possibly a speed sensor in a wheel bearing or the wiring connecting it.
Don06 is offline   Reply With Quote
Old 02-14-2011, 08:26 PM   #3
Senior Member
 
Join Date: 09-14-2007
Location: SoCAL & Louisville, KY
Member #: 4328
Posts: 3,415
Images: 117
Check out my gallery 
Sensor. I had the same issue when I was at about half your mileage recently. off/on, no real problem. Dealer took care of it pretty fast (i have extended warranty).

@
__________________

07 2LT - Sirius Blackie
Experience is the hardest teacher,
you get the final exam before the lesson.--Vin Scully

http://www.socalhhrs.info




afs9 is offline   Reply With Quote
Old 02-21-2011, 01:33 AM   #4
New Member
 
Join Date: 08-09-2006
Location: Southern California
Member #: 1716
Posts: 16
Check out my gallery 
Quote:
Originally Posted by afs9 View Post
Sensor. I had the same issue when I was at about half your mileage recently. off/on, no real problem. Dealer took care of it pretty fast (i have extended warranty).

@
What did they do to fix it?
ncampbell21 is offline   Reply With Quote
Old 02-21-2011, 12:05 PM   #5
Senior Member
 
Join Date: 09-14-2007
Location: SoCAL & Louisville, KY
Member #: 4328
Posts: 3,415
Images: 117
Check out my gallery 
Quote:
Originally Posted by ncampbell21 View Post
What did they do to fix it?
That's what the dealer is for! :)
I dropped it off in the morning, picked up in the afternoon.

Seriously, I have no clue what any of this means and that is why I have extended warranty -- they take care it.

Sorry can't be much help on that ...

@
__________________

07 2LT - Sirius Blackie
Experience is the hardest teacher,
you get the final exam before the lesson.--Vin Scully

http://www.socalhhrs.info




afs9 is offline   Reply With Quote
Old 02-21-2011, 12:35 PM   #6
Senior Member
 
Join Date: 03-06-2010
Location: Ohio
Member #: 19723
Posts: 5,328
Images: 120
Check out my gallery 
Quote:
Originally Posted by ncampbell21 View Post
I have 77K miles on my 2006 HHR and now the T/C light comes on and the T/C stays in gear. If you shut the engine off sometimes the light goes off and it goes out of T/C. It is starting to do it more often now.

Any ideas?
Can you explain this a little better... T/C light is on, any hard shifting? (if it's an automatic)

Does the light go out and stay out for any length of time? If so, for how long, etc. etc. This is probably not an actual T/C issue.
__________________

____ ***** October 2010 featured HHR ***** ____

>> 2.4L, GMPP, Trifecta, Ground Force/Progress suspension <<
Greybeard999 is offline   Reply With Quote
Old 02-21-2011, 12:45 PM   #7
Senior Member
 
Join Date: 01-10-2008
Location: NJ
Member #: 5298
Posts: 700
Images: 29
Check out my gallery 
I was under the impression that the T/C is always ON by default, and when you see the warning light, it is NOT engaged. Am I wrong?
__________________
<img src=http://www.chevyhhr.net/forums/images/smilies/bow.gif border=0 alt= title=Bow class=inlineimg /><img src=http://www.chevyhhr.net/forums/images/smilies/bow.gif border=0 alt= title=Bow class=inlineimg /><img src=http://www.chevyhhr.net/forums/images/smilies/bow.gif border=0 alt= title=Bow class=inlineimg /><img src=http://www.chevyhhr.net/forums/images/smilies/bow.gif border=0 alt= title=Bow class=inlineimg />
diskullman is offline   Reply With Quote
Old 02-21-2011, 01:37 PM   #8
Senior Member
 
Join Date: 03-06-2010
Location: Ohio
Member #: 19723
Posts: 5,328
Images: 120
Check out my gallery 
Correct
__________________

____ ***** October 2010 featured HHR ***** ____

>> 2.4L, GMPP, Trifecta, Ground Force/Progress suspension <<
Greybeard999 is offline   Reply With Quote
Old 02-21-2011, 01:47 PM   #9
Super Moderator
 
ChevyMgr's Avatar
 
Join Date: 11-23-2007
Location: Texas
Member #: 4865
Posts: 8,367
Images: 707
Check out my gallery 
Quote:
Originally Posted by diskullman View Post
I was under the impression that the T/C is always ON by default, and when you see the warning light, it is NOT engaged. Am I wrong?
Sort of wrong.

The system is always on by default, but it's not engaged until needed. When it engages the light and message should appear, then go out when the system is no longer engaged.
__________________
Some things I know, Some things I don't

ChevyMgr is offline   Reply With Quote
Old 02-21-2011, 01:49 PM   #10
Senior Member
 
Join Date: 03-06-2010
Location: Ohio
Member #: 19723
Posts: 5,328
Images: 120
Check out my gallery 
Okay, what he said ^^^^

It is "on" or ready to be engaged when needed by default though, correct?
__________________

____ ***** October 2010 featured HHR ***** ____

>> 2.4L, GMPP, Trifecta, Ground Force/Progress suspension <<
Greybeard999 is offline   Reply With Quote
Old 02-21-2011, 01:49 PM
 
 
 
submit to reddit
Reply

   
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:10 PM.
vBulletin copyright ©2000 - 2014, Jelsoft Enterprises Ltd. Vb Style © vb-skins.com

Advertising - Privacy Statement - Terms of Service - Cookies - Jobs

Copyright © 2005 - 2013 Internet Brands, Inc. All rights reserved.
Chevy HHR Network Forums