O2 sensor question - Chevy HHR Network

2.2L Performance Tech 16 valve 143 hp EcoTec with 150 lb-ft of torque

O2 sensor question

Old 01-10-2019, 07:57 PM
  #1  
New Member
Thread Starter
 
Join Date: 01-10-2019
Location: IL
Posts: 16
O2 sensor question

Originally Posted by donbrew View Post
If it will run with the stock tune, that seems like the easiest.

I think the O2 sensor monitors runs continuously or twice a drive, so I don't know how it could "be not ready".

I suppose you could try a battery disconnect lobotomy.

What is stock tune? I have same problem. O2 Sensor : Incomplete also Evaporative Sys: Incomplete
comandoed is offline  
Old 01-10-2019, 08:01 PM
  #2  
Administrator
 
Oldblue's Avatar
 
Join Date: 10-13-2011
Location: Welland,Ont Canada
Posts: 19,376
Sounds like your issue is for a 2.2 or 2.4, this thread pertains to the 2.0 Turbo SS
Oldblue is offline  
Old 01-10-2019, 08:01 PM
  #3  
Technical Moderator
 
donbrew's Avatar
 
Join Date: 01-23-2009
Location: Fredericksburg, Virginia
Posts: 16,418
"Not ready" means that the OBD2 test for the O2 sensors has not run. Did you disconnect the battery or clear codes recently?

What codes did you cl;ear?
donbrew is offline  
Old 01-11-2019, 01:07 AM
  #4  
New Member
Thread Starter
 
Join Date: 01-10-2019
Location: IL
Posts: 16
Originally Posted by donbrew View Post
"Not ready" means that the OBD2 test for the O2 sensors has not run. Did you disconnect the battery or clear codes recently?

What codes did you cl;ear?
Just bought wagon 4 days ago.
comandoed is offline  
Old 01-11-2019, 01:57 AM
  #5  
Platinum Member
 
Join Date: 04-09-2006
Location: Vancouver, BC, Canada
Posts: 6,604
comandoed- no one can really help you much unless you answer the questions raised to help diagnose the problems you are having.

Ie: Donbrew has asked two questions that you even quoted, yet you did not supply any answers.
whopper is offline  
Old 01-11-2019, 06:37 AM
  #6  
New Member
Thread Starter
 
Join Date: 01-10-2019
Location: IL
Posts: 16
Please follow thread more carefully. I am not asking for help. My initial question was "What is stock tune?". I was trying to simply educate myself.

The answer to his question, I thought was implicit when I replied that I had just bought the car 4 days ago and that that is how the car came.
I commented about my "incompletes" for conversation sake only. Maybe I should not have.

At this point I am not asking for any help. Sorry for the misunderstanding!
comandoed is offline  
Old 01-11-2019, 07:27 AM
  #7  
Platinum Member
 
firemangeorge's Avatar
 
Join Date: 12-06-2009
Location: Fairhope, Alabama
Posts: 8,444
Yes comandoed, please follow the "thread" more carefully.
This is a thread about the SS HHR. (it is in the SS specific forum) Your bio shows you have a 2007 so it is not a SS.
You stated : quote "I have same problem. O2 Sensor : Incomplete also Evaporative Sys: Incomplete" To me, that reads as you've got a problem and you're looking for help.
firemangeorge is offline  
Old 01-11-2019, 08:00 AM
  #8  
Technical Moderator
 
donbrew's Avatar
 
Join Date: 01-23-2009
Location: Fredericksburg, Virginia
Posts: 16,418
Stock tune is what comes from the factory.

BTW, I did follow the thread. Your first post was #6 and stated "same problem" but evidently is not.

Bye.
donbrew is offline  
Old 01-11-2019, 10:23 AM
  #9  
Administrator
 
Oldblue's Avatar
 
Join Date: 10-13-2011
Location: Welland,Ont Canada
Posts: 19,376
Thread separation, moved this to the 2.2 files.
Oldblue is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
2005HHRauto
Problems/Service/Repairs
4
06-14-2012 03:48 PM
lake
General HHR
21
08-10-2008 07:59 AM


Thread Tools
Search this Thread
Quick Reply: O2 sensor question


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands