Battery light stuck on - Chevy HHR Network

Go Back  Chevy HHR Network > General Discussion > General HHR
Reload this Page >

Battery light stuck on

General HHR Discuss anything related to the Chevy HHR that doesnt seem to fit into the more specific categories below.

Battery light stuck on

Reply

 
 
 
Old 05-14-2018, 04:37 PM
  #1  
Senior Member
Thread Starter
 
hurst2001's Avatar
 
Join Date: 09-03-2006
Location: chicago
Posts: 389
Battery light stuck on

Ok guys got a 2007 with about 258000 and my wife hit a bump and light came on .. there are no messages no check engine light just battery .. possible alternator going or what the best way to check it thanks
hurst2001 is offline  
Reply With Quote
Old 05-14-2018, 04:56 PM
  #2  
Moderator
 
RJ_RS_SS_350's Avatar
 
Join Date: 05-01-2014
Location: California
Posts: 3,102
Let the auto parts store test your battery and charging system.

Inspect the serpentine belt.

See if the battery connections in the back and at the fuse block are tight and clean.
RJ_RS_SS_350 is offline  
Reply With Quote
Old 05-14-2018, 06:07 PM
  #3  
Senior Member
Thread Starter
 
hurst2001's Avatar
 
Join Date: 09-03-2006
Location: chicago
Posts: 389
Originally Posted by RJ_RS_SS_350 View Post
Let the auto parts store test your battery and charging system.

Inspect the serpentine belt.

See if the battery connections in the back and at the fuse block are tight and clean.
ok went to autozone and they tell me the battery is at 74 percent .. so I went to test with the meter car off it at 12.58 with everything on it was at 10.88 so Iím guessing got to be the alternator not charging?
hurst2001 is offline  
Reply With Quote
Old 05-14-2018, 06:36 PM
  #4  
Moderator
 
RJ_RS_SS_350's Avatar
 
Join Date: 05-01-2014
Location: California
Posts: 3,102
You didn't have them test the charging system?

The battery might be bad.
RJ_RS_SS_350 is offline  
Reply With Quote
Old 05-14-2018, 06:42 PM
  #5  
Premium Member
 
firemangeorge's Avatar
 
Join Date: 12-06-2009
Location: Fairhope, Alabama
Posts: 8,166
Originally Posted by hurst2001 View Post


ok went to autozone and they tell me the battery is at 74 percent .. so I went to test with the meter car off it at 12.58 with everything on it was at 10.88 so Iím guessing got to be the alternator not charging?
Did you look and see if the serpentine belt is there ?

Like RJ stated. If you went to AZ, you should have had them check the entire charging system, including the battery.
firemangeorge is offline  
Reply With Quote
Old 05-14-2018, 06:56 PM
  #6  
Senior Member
Thread Starter
 
hurst2001's Avatar
 
Join Date: 09-03-2006
Location: chicago
Posts: 389
Originally Posted by firemangeorge View Post
Did you look and see if the serpentine belt is there ?

Like RJ stated. If you went to AZ, you should have had them check the entire charging system, including the battery.
well girl tells me that she canít because the battery is weak Iím like really .. the place is useless I told her to check the alternator but thatís what I get ..and yes the serpentine is there .. and seen a liitte smoke rising in that area .. I mean 258000 on the original alternator is pretty good I think ..
hurst2001 is offline  
Reply With Quote
Old 05-14-2018, 08:23 PM
  #7  
Administrator
 
Oldblue's Avatar
 
Join Date: 10-13-2011
Location: Welland,Ont Canada
Posts: 17,942
A little smoke in that area, you mean the alternator? It could be it’s cooking out!
Oldblue is offline  
Reply With Quote
Old 05-14-2018, 08:29 PM
  #8  
Technical Moderator
 
donbrew's Avatar
 
Join Date: 01-23-2009
Location: Fredericksburg, Virginia
Posts: 15,490
True they can't check the alternator with a dead battery.

From your description of the onset, my guess would be a loose wire.
donbrew is offline  
Reply With Quote
Old 05-14-2018, 08:44 PM
  #9  
Senior Member
Thread Starter
 
hurst2001's Avatar
 
Join Date: 09-03-2006
Location: chicago
Posts: 389
Originally Posted by donbrew View Post
True they can't check the alternator with a dead battery.

From your description of the onset, my guess would be a loose wire.
the battery tested at 74 percent when I put a load on it everything on it drop 10.88 .. all I seen some smoke coming from the alternator area so I shut the car off .. so I feel that the brushes in alternator seen better days.. the car starts right up so I not sure but I will take to a shop I that I trust to see whatís the deal ..
hurst2001 is offline  
Reply With Quote
Old 05-15-2018, 08:33 AM
  #10  
Technical Moderator
 
donbrew's Avatar
 
Join Date: 01-23-2009
Location: Fredericksburg, Virginia
Posts: 15,490
12.0 V is dead.

Electrical equipment won't work without the magic smoke, once it is released there is no hope.
donbrew is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Battery light stuck on


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service