need help with p2122 code - Chevy HHR Network


Problems/Service/Repairs If you have a problem with your HHR, want a tip on repairing or performing a particular service to you HHR here is the place to post!

Reply
 
 
 
Thread Tools Search this Thread
Old 03-20-2016, 07:07 AM   #1  
Member
Thread Starter
 
Join Date: 04-08-2008
Location: georgia
Posts: 40
need help with p2122 code

My 2006 HHR left me stranded at gf's house yesterday. Code is p2122.
Engine idles perfect...just will not go regardless of where gas pedal is pressed.
Cleared code and car now runs great. Any suggestions?
Thanks for your help
Eddie
sunset is offline   Reply With Quote
Old 03-20-2016, 07:39 AM   #2  
Premium Member
 
firemangeorge's Avatar
 
Join Date: 12-06-2009
Location: Fairhope, Alabama
Posts: 7,963
P2100 Throttle Actuator Control (TAC) Motor Control Circuit
P2101 Throttle Actuator Position Performance
P2105 Throttle Actuator Control (TAC) System Forced Engine Shutdown
P2119 Throttle Closed Position Performance
P2120 Accelerator Pedal Position (APP) Sensor 1 Circuit
P2122 Accelerator Pedal Position (APP) Sensor 1 Circuit Low Voltage
P2123 Accelerator Pedal Position (APP) Sensor 1 Circuit High Voltage
P2125 Accelerator Pedal Position (APP) Sensor 2 Circuit
P2127 Accelerator Pedal Position (APP) Sensor 2 Circuit Low Voltage
P2128 Accelerator Pedal Position (APP) Sensor 2 Circuit High Voltage
P2135 Throttle Position (TP) Sensor 1-2 Correlation
P2138 Accelerator Pedal Position (APP) Sensor 1-2 Correlation

Since you have the code, now it's time for a little diagnostic work to see what triggered the code on your car.
firemangeorge is offline   Reply With Quote
Old 03-20-2016, 07:41 AM   #3  
Technical Moderator
 
donbrew's Avatar
 
Join Date: 01-23-2009
Location: Fredericksburg, Virginia
Posts: 14,846
From your description it sounds like the pedal has gone bad.
donbrew is offline   Reply With Quote
Old 03-20-2016, 07:43 AM   #4  
Administrator
 
Oldblue's Avatar
 
Join Date: 10-13-2011
Location: Welland,Ont Canada
Posts: 17,126
Either the pedal or a loose or dirty connection.
How is the battery, could be the source of the low voltage issues
Oldblue is offline   Reply With Quote
Old 03-20-2016, 07:47 AM   #5  
Member
Thread Starter
 
Join Date: 04-08-2008
Location: georgia
Posts: 40
Thanks guys,
I'm already thinking about the accelerator pedal position sensor. Found one for $60 new online.
Thanks again
sunset is offline   Reply With Quote
Old 11-29-2017, 05:54 PM   #6  
 
Join Date: 11-29-2017
Location: levittown pa
Posts: 3
I'm having the exact same problem. Did the pedal sensor resolve your issue?
rfrumin is offline   Reply With Quote
Old 11-29-2017, 07:58 PM   #7  
Technical Moderator
 
donbrew's Avatar
 
Join Date: 01-23-2009
Location: Fredericksburg, Virginia
Posts: 14,846
Quote:
Originally Posted by rfrumin View Post
I'm having the exact same problem. Did the pedal sensor resolve your issue?
EXACT?

Including clearing the code and it is fixed? And being a 2006?

This thread is more than a year old The OP has not returned to let us in on his progress.
So, we need much more specifics from you.
donbrew is offline   Reply With Quote
Old 11-29-2017, 08:22 PM   #8  
 
Join Date: 11-29-2017
Location: levittown pa
Posts: 3
Quote:
Originally Posted by donbrew View Post
EXACT?

Including clearing the code and it is fixed? And being a 2006?

This thread is more than a year old The OP has not returned to let us in on his progress.
So, we need much more specifics from you.
06, P2122 (only code), idles fine, but DIC displays eng power reduced and basically 0 power, wont go over 20. The problem is not fixed and I did not clear the code, that's why I'm asking if it was fixed. In all of those posts I've read that are similar to my issue, clearing the code "fixes the problem for 2 to 3 days" then it returns.

I mean not stone cold iron clad definition of exact.....but close enough
rfrumin is offline   Reply With Quote
Old 11-29-2017, 08:46 PM   #9  
Technical Moderator
 
donbrew's Avatar
 
Join Date: 01-23-2009
Location: Fredericksburg, Virginia
Posts: 14,846
Then most likely the pedal assembly or the electrical connector.

It basically means the #1 sensor is shorting to ground. The 2 sensors have LowRef 5VRef and signal. Basically 2 rheostats.
donbrew is offline   Reply With Quote
Old 11-30-2017, 07:51 AM   #10  
 
Join Date: 11-29-2017
Location: levittown pa
Posts: 3
Where is the #2 sensor? on the TB?

I'm thinking of trying to crack open the #1 pedal sensor and seeing if some alcohol or electrical contract cleaner will help. Unless of course it's totally sealed.
rfrumin is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
P0014 code and "fix" NEED HELP! Agpullen Problems/Service/Repairs 12 02-06-2016 05:53 PM
need help with a code p0010 cam sensor bank 1 and p0011 [email protected] SS Specific Service Issues/Repairs 23 07-01-2015 12:31 PM
P300 code yesterday, 420 code today. edgarfrog Problems/Service/Repairs 8 10-25-2013 08:43 AM
p1174 code and misfire code LtGhost08 Problems/Service/Repairs 4 06-10-2013 02:13 PM
P2122/P2127 code tkfross Problems/Service/Repairs 0 10-25-2012 08:55 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:48 AM.


Copyright © 2005 - 2017 Internet Brands, Inc. All rights reserved.