Windshield washer pump dead. - Chevy HHR Network

Go Back  Chevy HHR Network > General Discussion > Problems/Service/Repairs
Reload this Page >

Windshield washer pump dead.

Problems/Service/Repairs If you have a problem with your HHR, want a tip on repairing or performing a particular service to you HHR here is the place to post!

Windshield washer pump dead.

Reply

 
 
 
Old 09-16-2009, 05:04 AM
  #1  
Senior Member
Thread Starter
 
Join Date: 06-02-2008
Location: Fairport Harbor, OH
Posts: 2,358
Windshield washer pump dead.

My washers don't squirt anymore. I can't here the pump motor make any sound. I checked and reseated all the fuses. Anyone ever heard of this before? I also checked the wiring to the pump for anything obvious. I didn't go into it any deeper.
Jeff® is offline  
Reply With Quote
Old 09-16-2009, 05:41 AM
  #2  
Platinum Member
 
Join Date: 07-17-2006
Location: Dallas, GA
Posts: 5,940
I've had to replace one on a different vehicle before.
solman98 is offline  
Reply With Quote
Old 09-16-2009, 05:39 PM
  #3  
Member
 
Join Date: 05-14-2009
Location: Oshawa ON
Posts: 47
I've replaced a few on past vehicles. Not all that unusual.
Darkangel is offline  
Reply With Quote
Old 09-18-2009, 08:15 AM
  #4  
Senior Member
Thread Starter
 
Join Date: 06-02-2008
Location: Fairport Harbor, OH
Posts: 2,358
I went to the dealer yesterday. Bad pump. They had to order it...

I ded get a new keyfob though because the 'unlock' button wouldn't work any more.
Jeff® is offline  
Reply With Quote
Old 11-10-2009, 05:34 PM
  #5  
Member
 
Join Date: 02-04-2008
Location: Akron, Ohio
Posts: 61
Hey Jeff,
when the pump was dead - did you hear anything at all under the hood?
The washer pump on our '08 LT is not pumpin' but I hear a faint click
under the hood when either washer control is used. (front or back)

Is this a warranty item per chance? :-)

Jim
Biff is offline  
Reply With Quote
Old 11-10-2009, 06:37 PM
  #6  
Senior Member
 
Join Date: 02-16-2009
Location: Frankenmuth/Flint, MI
Posts: 6,038
I had that happen on mine...but my fluid froze up. It was winter and the dealer put some cheap stuff in that couldn't take the cold.... Gotta love dealers that are going out of business...
urbexHHR is offline  
Reply With Quote
Old 07-25-2012, 11:25 AM
  #7  
Member
 
Join Date: 09-29-2011
Location: Ohio
Posts: 48
I know this is an old thread but I think mine died too. Wipers work but nothing squirts. I do not hear anything when I push the button to call for fluid.

Reservoir is full. I filled it last week before vacation and changed the blades. Checked operation then and they squirted fine.
It rained a little bit while on vacation and the wipers chattered for a few minutes. Not sure if it is because it spit rain and windows were not wet enough and just coincidence that the fluid will not squirt now or is all somehow connected together.

Any ideas?
ghostdragon is offline  
Reply With Quote
Old 07-25-2012, 12:21 PM
  #8  
Founding Member
 
ChevyMgr's Avatar
 
Join Date: 11-23-2007
Location: Texas
Posts: 8,176
Originally Posted by ghostdragon View Post
I know this is an old thread but I think mine died too. Wipers work but nothing squirts. I do not hear anything when I push the button to call for fluid.

Reservoir is full. I filled it last week before vacation and changed the blades. Checked operation then and they squirted fine.
It rained a little bit while on vacation and the wipers chattered for a few minutes. Not sure if it is because it spit rain and windows were not wet enough and just coincidence that the fluid will not squirt now or is all somehow connected together.

Any ideas?
Replace the pump. Using the wipers will not damage the pump, it's just a dead pump.
ChevyMgr is offline  
Reply With Quote
Old 07-29-2012, 10:37 PM
  #9  
Member
 
Join Date: 09-29-2011
Location: Ohio
Posts: 48
I did not think using the wipers would damage the pump. I just wondered if there was any connection.
I finally popped the hood and the reservoir is almost empty. It was full before vacation and I did not use the sprayer while on my trip. So where did all the fluid go? Do I have a bigger issue than a dead pump? Did it leak out from the pump?

Also, is it difficult to change the pump?
ghostdragon is offline  
Reply With Quote
Old 07-29-2012, 10:41 PM
  #10  
Admin Emeritus
 
843de's Avatar
 
Join Date: 06-30-2010
Location: Kannapolis NC
Posts: 25,773
You may find the washer bottle/tank is cracked, it looks like a pretty simple job, the washer bottle and pump are only held in with three bolts. One at the front, one at the back, and one on the inner fender.
843de is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Windshield washer pump dead.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service