Drivetrain (Excluding Engine) Transmission, axles, clutches or other drive-line related discussion.

trans problem?

Old 01-13-2015, 10:01 PM
  #1  
Thread Starter
 
Join Date: 01-13-2015
Location: E.S.V.A
Posts: 1
trans problem?

Hi everyone! I've got some transmission problems I'm hoping someone might be able to help with some info. I got a 06 hhr and it won't go over 35. Its got two codes p1818 (tfp valve) and p0977 (shift solenoid). would i have to have just the valve and solenoid replaced or a rebuild?
crimsonsoljuh is offline  
Old 01-14-2015, 07:22 AM
  #2  
Administrator
 
Oldblue's Avatar
 
Join Date: 10-13-2011
Location: Welland,Ont Canada
Posts: 20,436
A quick Google search indicates a possible faulty TCM , bad shift solenoid or simply flush the trans fluid and change the filter. One post suggested it could be the MAF sensor
Seeing as the P1818 was the first code it most likely set the other code, therefore I suggest reset the TCM and ECM by disconnecting the neg battery terminal in the spare tire well, place a folded towel on the hatch latch so you don't get locked out, wait 30 minutes, then reconnect the neg terminal.
When the MIL comes back on have the code read and post it up here, it could be the terminal to the TCM has a loose connection or has just needed to be reset also check the under hood fuse box ensure all fuses and relays are pushed in and seated firmly.
First step , let us know
Oldblue is online now  
Old 03-25-2015, 10:31 AM
  #3  
Administrator
 
Oldblue's Avatar
 
Join Date: 10-13-2011
Location: Welland,Ont Canada
Posts: 20,436
Well one and done!!!
My HHR 2007 2.2 auto had the issue pop up yesterday with the auto lock not working or the cruise! I connected my code reader and it showed a pending P1818 code.
I disconnected the negative terminal at the battery and inspected the negative connections at the transmission and the rad cradle, clean and tight!
Reconnected the battery and everything is back to normal, for now I'll keep you posted!!!
Oldblue is online now  
Old 03-25-2015, 06:42 PM
  #4  
Technical Moderator
 
donbrew's Avatar
 
Join Date: 01-23-2009
Location: Fredericksburg, Virginia
Posts: 17,243
I got Transmission Neutral Safety Switch Short Circuit To Battery

Read more: P1818 Transmission Neutral Safety Switch Short Circuit To Battery OBDII Engine Light Trouble Code | Engine-Codes.com

Sounds like a ground wire somewhere.
donbrew is online now  
Old 03-26-2015, 06:43 AM
  #5  
Administrator
 
Oldblue's Avatar
 
Join Date: 10-13-2011
Location: Welland,Ont Canada
Posts: 20,436
While the battery was disconnected I did check the ground wires at the transmission and the rad cradle both were snug, I believe I might have caused the issue when I took the shifter out to replace the indicator bulb , we'll see
Oldblue is online now  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Lethal Tendencies
Problems/Service/Repairs
9
01-21-2013 12:30 PM
10RedSS
Problems/Service/Repairs
12
10-25-2011 09:16 PM
urbexHHR
The Lounge
82
11-03-2010 07:00 AM
GrotesqueFetus6
Problems/Service/Repairs
18
10-22-2009 09:19 PM
ts5p
HHR SS
3
10-06-2008 02:47 PM


Thread Tools
Search this Thread
Quick Reply: trans problem?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands